wyszukajpionowo.pl - analizy danych, raporty, Excel, analiza, tworzenie makr VBA, automatyzacja prezentacji, makra Visual Basic

Excelowe funkcje informacyjne

Funkcje informacyjne w MS Excel to świetna pomoc, która wspiera analizę dużej ilości danych. Poniżej zamieszczam przykłady funkcji przydatnych w pracach analitycznych.

KOMÓRKA - funkcja pokazująca informacje nt. zawartości, położenia i formatowania komórki.

Składnia funkcji: KOMÓRKA(typ_info;[odwołanie])

Najbardziej przydatne wg. mnie typy informacji wspierające przetwarzanie danych:
• kolumna – pokazuje numer kolumny wskazanej komórki,
• wiersz – pokazuje numer wiersza wskazanej komórki,
• adres – pokazuje adres excelowy wybranej komórki np. $B$5,
• zawartość – pokazuje wartość komórki zamiast formuły,
• nazwa_pliku – wyświetla nazwę pliku i ścieżkę prowadzącą do plik (w nazwie zawarta będzie też nazwa arkusza),
• typ - wartość komórki będzie zamieniona na typ danych: „b”, „blank”, „l” pusta komórka, „v”, inna wartość liczbowa.

Jeżeli przed wykonaniem obliczeń (np. mnożenie komórki) sprawdzamy, czy zawiera ona wartość liczbową, należy wpisać formułę:
= JEŻELI(KOMÓRKA("typ";B5)="v";B5*5;0)

Wartość B5*5 będzie obliczona tylko jeżeli B5 jest liczbą. Jeżeli w komórce jest tekst lub nie ma nic, wyświetlana wartość komórki to 0.

TYP – funkcja wyświetla typ wartości: 1 – liczba, 2 - tekst, 4 - wartość logiczna, 16 – błąd, 64 – tablica. Funkcję można stosować do komórek z formułami, ale należy pamiętać, że odnosi się ona do wyniku obliczeń, a nie formuły excelowej.

Składnia funkcji to: = TYP(B5)

NR.BŁĘDU - zastosowanie w Excelu pozwala wyświetlić wartość błędu zgodnie z poniższą tabelką zawierającą numery błędów:
• #ZERO! - 1
• #DZIEL/0! - 2
• #ARG! - 3
• #ADR! - 4
• #NAZWA? - 5
• #LICZBA! - 6
• #N/D! - 7
• #POBIERANIE_DANYCH - 8
• Inne - #N/D!

Pełniejszy obraz funkcji informacyjnych możecie znaleźć w naszym artykule na stronie centrumpr.pl.

raporty-analizy-excel-funkcje-informacyjne